Board index

PCGen


IT IS ALIVE!!!

UI issue

Where new users can post questions about PCGen, or report possible issues (bug tracking is by Jira - jira.pcgen.org)

UI issue

Postby CapnPip » Thu May 31, 2018 4:30 am

I'm having a problem where the UI keeps bugging out.
Everything works fine for a while but then something breaks and the UI starts redrawing every time the cursor moves over a button, but it's aligned with the cursor and not the top left of the window where it's supposed to be.

Image

PCGen version 60601
indows 10
User avatar
CapnPip
 
Posts: 3
Joined: Thu May 31, 2018 3:48 am

Re: UI issue

Postby LegacyKing » Thu May 31, 2018 6:22 am

Old version, try 6.07.08

Also:
Mouse Over Issues for some users
Solution: run Command Line, navigate to your PCGen installed files "cd c:\the\path\to\pcgen" and type in:

java "-Dsun.java2d.d3d=false" -jar .\pcgen.jar


High Resolution Display
I was able to workaround this issue by going into the compatibility properties of the PCGen shortcut and setting the "Override high DPI scaling behavior" to System. This was tested on Windows 10.

Right click PCGen app, Select Properties, then Compatibility, then turn on Override High DPI scaling.


Andrew Maitland
PCGen Content SB
- Data Chimp
- Quicksilver Tracker Monkey
User avatar
LegacyKing
Site Admin
 
Posts: 768
Joined: Fri Oct 11, 2013 12:35 pm
Location: California, US

Re: UI issue

Postby CapnPip » Thu May 31, 2018 3:34 pm

LegacyKing wrote:Mouse Over Issues for some users
Solution: run Command Line, navigate to your PCGen installed files "cd c:\the\path\to\pcgen" and type in:

java "-Dsun.java2d.d3d=false" -jar .\pcgen.jar


This works.

I'll still switch to the new version, but the source files the group is using don't work. So i'll just ahve to use this as a stopgap.

Can I stick this in a batch file so I don't have to navigate in cmd?
User avatar
CapnPip
 
Posts: 3
Joined: Thu May 31, 2018 3:48 am
Top

Re: UI issue

Postby LegacyKing » Fri Jun 01, 2018 12:19 am

Why don't the files work?


Andrew Maitland
PCGen Content SB
- Data Chimp
- Quicksilver Tracker Monkey
User avatar
LegacyKing
Site Admin
 
Posts: 768
Joined: Fri Oct 11, 2013 12:35 pm
Location: California, US
Top

Re: UI issue

Postby CapnPip » Fri Jun 01, 2018 12:50 am

I don't know, most likely a problem with the .lst files.

To clarify, these aren't the sources PCGen comes with.
User avatar
CapnPip
 
Posts: 3
Joined: Thu May 31, 2018 3:48 am
Top


Return to Questions & Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron